Honeywell Silent Knight SK-5208 - "Com 0 Trb"

I am a low-voltage alarm contractor in Georgia and I am donating my time to an organization for retrofitting an outdated conventional FACP. I received a donation of a new Honeywell SK-5208 FACP and peripherals for the work effort. All said, and not having much experience with this panel, or for that matter, much of the Honeywell products, I have run into a “Com 0 Trb” that prevents the dialer from operating. It is a simple system to install and operate so I am at a loss on resolving the issue. I have submitted a ticket with Honeywell, but since I am not a distributor of their products, the response has been very slow from the tech support team. So, from your experience, is this a hardware issue, firmware, or? Thanks in advance for your expert advice :wink:

1 Like

The 5208 uses two telephone lines to communicate status information to a central station. Have you programmed the central station phone numbers, account number and dialer format?

1 Like

are the wires connected to the dialer, and if yes are they wired correctly?

1 Like

From the book:

Com # Trb

The SK-5208 must use alternating phone lines (according to NFPA) when reporting auto tests and manual tests. If the control panel can not communicate using the selected phone line, the Com # Trb message will be displayed. The # indicates which line had the trouble.

The trouble condition will clear after the control panel is successful in communicating using the phone line.

######################################

Seems kind of strange that 0, instead of 1 (line 1) or 2 (line 2). Of course, though Silent Knight may use 0 and 1 for line 1 and line 2. IDK, rarely pay attention to that. I program systems with a laptop. First, see if your phone line has 52VDC (or so) on hook. 6 VDC (or so) off hook. (assuming you have a phone line)

My suspicion is a programming issue. You could disable the dialer if you aren’t needing to be monitored. If you need to be monitored, get your info together and likely one of us can tell you how to program the various fields. Of course, though, there may be a problem at the other end of the connection.

Thanks to all of you for the feedback and advice. I have verified everything that was suggested. I spoke with Honeywell Tech support directly about this issue. The indication is that the system is defective. It does seem odd that everything else in the system works correctly as programmed.

I also use the SKSS application to program the hardware and I did verify the updates were “seen” on the panel. Even if I disable the dialer function, the system continues to indicate a “Com 0 Trb.”

I was thinking that the issue may have been the need to update the firmware or reflash the OS, but the tech guys didn’t have a clue what I had suggested. I didn’t smell any smoke nor do I see any surface evidence of burn marks on the surface of the motherboard. I have a new board on order with ADI. I am told 6 - 8 weeks at best :frowning: and I have a very unhappy customer …

Any more ideas?

you might have to disconnect the dialer for the time being
you could also install a radio / GSM dialer instead which I think might need to be connected to the alarm relay