Strange mouse behavior

This is a problem that just started happening with my desktop PC. At first, I thought it was a problem exclusively through my video editing program (Sony Vegas), but that, ultimately was not the case.

As an example, in Sony Vegas, in the media bin, if I try to scroll up using the scroll wheel, it scrolls all the way back down.

I found out the hard way when I was trying to address this issue to a friend of mine who knows me best for some of my non-FA videos on YouTube through TeamViewer (and Discord before and during).

To cut a long story short, the scrolling problem ultimately made it impossible for anyone to control my desktop. It caused the Access Control option in the drop-down menu to go down to “Deny incoming remote control sessions” (which, unfortunately, is the last item in that menu). If I tried to pick any of the other options other than the very last option in that drop down menu, it will automatically scroll back down to said very last option.

I’ve opened up other programs and settings from the Control Panel to see if the problem still persists on drop down menus. My suspicion was correct.



OS: Windows 7 Professional


Custom-built tower PC.

Mouse: Tecknet M002 wireless mouse

Here’s all of the things I’ve tried

  • Restarting the computer (twice, the second time being when my friend suggested it over Discord)
  • Installed 1 update (yes there was only one update available) but it didn’t require a restart
  • Scanned for viruses (Quick Scan via Microsoft Security Essentials), no threats found
  • Tried updating mouse drivers
  • Turning off the mouse (and back on again; see below)

    Even when I had the mouse turned off, the problem still persists. What could be the problem here? Should I get another mouse? Most likely I will have to do that anyway since 1. I’ve never had this problem with my Microsoft Wireless Mobile Mouse 4000 (used for my laptop PC), and, 2. sadly I have another one (which was supposed to be a spare).

I forgot to mention that I’ve also tested to see if the battery was low. The battery was fine (my multimeter read slightly more than 1.4 volts).

Additionally, I had suspected that maybe it was one of the keys on my keyboard. That was not the case.

Again, if anyone knows what the problem could be, let me know.

I would try unplugging the receiver for the mouse and try a generic, run of the mill USB mouse and see if that makes a difference. Try the same with your keyboard if that doesn’t work. If none of those work, I will try to think of other things that could be the problem.

Actually, I already fixed the problem yesterday, but I was too lazy to address that. All I did was disconnect the receiver for the mouse, scrolled through a drop-down menu using the arrow keys on my keyboard (in this case, the Region and Language settings), and then plugged it back in, and the scrolling behavior disappeared. In other words, the problem was solved the moment I disconnected said receiver.